USB Loopback not getting saved in VST

Post Reply
joshebosh
Posts: 57
Joined: Thu May 13, 2021 9:59 pm

USB Loopback not getting saved in VST

Post by joshebosh »

Hey Rob,

What do you make of this, possible bug?

I'm using FL Studio with ME VST

In VST this loopback setting will not save...
I have two presets, Drums (loopback disabled) and Synths (loopback enabled)...
The loopback param/variable will remain whatever i last toggled it to manually, regardless of which preset i choose, saved, resaved...
leading me to believe this particular value might not be getting reported to the values saved list?
AutoHotkeyU32_s4kYtm3v7Q.png
AutoHotkeyU32_s4kYtm3v7Q.png (62.15 KiB) Viewed 4326 times
example steps:
1 Disable the USB loopback
2 save a DAW VST preset like "Drums"
3 enable the USB loopback
4. save a DAW VST preset like "Synths"
5. load the "Drums" preset
6 the USB loopback will still be enabled, but should be disabled at this point

This does not appear to happen in standalone using Snapshot Manager
Only happens in VST
User avatar
Rob
Site Admin
Posts: 4478
Joined: Sat Aug 01, 2009 2:04 pm

Re: USB Loopback not getting saved in VST

Post by Rob »

Thanks for the detailed report of the issue. Should be an easy fix. I'll look into it today.
User avatar
Rob
Site Admin
Posts: 4478
Joined: Sat Aug 01, 2009 2:04 pm

Re: USB Loopback not getting saved in VST

Post by Rob »

Fixed. It's be available in the next update.
joshebosh
Posts: 57
Joined: Thu May 13, 2021 9:59 pm

Re: USB Loopback not getting saved in VST

Post by joshebosh »

awesome, thank you!
User avatar
Rob
Site Admin
Posts: 4478
Joined: Sat Aug 01, 2009 2:04 pm

Re: USB Loopback not getting saved in VST

Post by Rob »

It should be fixed in version 2.9.2.1, although I haven't tested thoroughly .

viewtopic.php?f=26&t=1981&p=13523#p13523
Post Reply