PDX-10 Snare Trigger Issues

A collection of useful threads for troubleshooting issues.
vdrummerguy
Posts: 21
Joined: Sat Oct 16, 2021 2:11 am

PDX-10 Snare Trigger Issues

Post by vdrummerguy »

Hi I'm on version 1.6 older version of FW on eDrumin10 and I'm having an issue with the snare where while hitting the head in the center of the PDX-10 at some points during play it will start to register these hits as if they were toward the edge of the pad. It will get stuck like this for a bit with several more hits in the center generating a sound as if you're hitting the edges of the pad. After a little bit of this behavior then the pad starts to provide the correct sounds again, seems to right itself again.

I've messed with the settings, turned hotspot suppression off, turned off positional sensing as well, but it doesn't do anything to help the problem, so wanted to write here to see if any way to fix it. Here's a pic of my current settings for the pad.
Screenshot_20240522_232306.jpg
Screenshot_20240522_232306.jpg (140.56 KiB) Viewed 1255 times
Thanks in advance for any help.
User avatar
Rob
Site Admin
Posts: 4516
Joined: Sat Aug 01, 2009 2:04 pm

Re: PDX-10 Snare Trigger Issues

Post by Rob »

That's pretty old firmware and a lot has changed since then, including lots of bug fixes and improved functionality. Are you setup in a DAW environment?
vdrummerguy
Posts: 21
Joined: Sat Oct 16, 2021 2:11 am

Re: PDX-10 Snare Trigger Issues

Post by vdrummerguy »

I'm using Superior Drummer 3 via a Scarlett Focusrite audio interface, for recording I use Presonus Studio One 5. I'm hesitant to upgrade the firmware as I'm afraid it's going to mess something up with my setup. Other than this one issue, everything is really working perfectly. If this one thing were fixed then it'd be perfect. Are there any setting changes that you think would help?

Also, the problem manifests itself regardless of whether I'm recording.
User avatar
Rob
Site Admin
Posts: 4516
Joined: Sat Aug 01, 2009 2:04 pm

Re: PDX-10 Snare Trigger Issues

Post by Rob »

I assume the problem goes away if you completely disable possitional sensing and restart SD3?
vdrummerguy
Posts: 21
Joined: Sat Oct 16, 2021 2:11 am

Re: PDX-10 Snare Trigger Issues

Post by vdrummerguy »

I disabled it, but I never also restarted SD3 along with doing that, I'll give that a try.

I guess there's more benefits to upgrading the firmware? Is there any downsides to doing it? Can I revert back to what I was on previously? Will it mess with any of my current settings? Could the upgrade also fix my issue I'm having?
User avatar
Rob
Site Admin
Posts: 4516
Joined: Sat Aug 01, 2009 2:04 pm

Re: PDX-10 Snare Trigger Issues

Post by Rob »

If you update to the latest version, you won't be able to downgrade without losing your settings. I can't promise the update process will preserve all your settings as there have been a lot of changes since version 1.6 and I just don't have the resources to test updating from very older firmware. Also, I can't promise that it'll fix your snare issue. Probably not the answers your want to hear, but that's all I got for you.
vdrummerguy
Posts: 21
Joined: Sat Oct 16, 2021 2:11 am

Re: PDX-10 Snare Trigger Issues

Post by vdrummerguy »

Well I'd rather hear the truth about it, so I can make an informed decision. Regardless of the firmware upgrade, why do you think this snare issue exists at all? I guess I need to read up on all the firmware changes in order to make a decision about it.

Either way thank you for the quick replies!
vdrummerguy
Posts: 21
Joined: Sat Oct 16, 2021 2:11 am

Re: PDX-10 Snare Trigger Issues

Post by vdrummerguy »

Rob wrote:
Thu May 23, 2024 4:40 am
I assume the problem goes away if you completely disable possitional sensing and restart SD3?
I tried this and it didn't work, the problem persists ;(

This is the only issue I have really, everything else works perfectly, how can it be fixed? I'm just trying to do some song covers and I can't get through a song without it happening and ruining the take.
User avatar
Rob
Site Admin
Posts: 4516
Joined: Sat Aug 01, 2009 2:04 pm

Re: PDX-10 Snare Trigger Issues

Post by Rob »

I'm guessing that some other pad has positional sensing on and is sending CC16. Check your other inputs and the SD3 MIDI log to confirm.
vdrummerguy
Posts: 21
Joined: Sat Oct 16, 2021 2:11 am

Re: PDX-10 Snare Trigger Issues

Post by vdrummerguy »

Rob wrote:
Fri May 24, 2024 10:31 pm
I'm guessing that some other pad has positional sensing on and is sending CC16. Check your other inputs and the SD3 MIDI log to confirm.
I've seen it does go away if I hit the first tom then go back to the snare, maybe that's causing it. I'll have to check like you're saying, thank you
Post Reply